Degraded Performance

Incident Report for BlueTally

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 21:39 UTC

Investigating

We are currently investigating this issue.
Posted Feb 18, 2025 - 17:06 UTC
This incident affected: BlueTally App and BlueTally API.